PTA甲级——1008

1008 Elevator

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

1
3 2 3 1

Sample Output:

1
41

思路

​ 大致意思:你一开始在0楼,给一个数n,表示你将要到达的楼层数,往上走一层需要6s,往下走需要4s,每一站都要停5s,需要你计算所有的时间。这里需要注意:你到最终站的时候还需要停留5s.

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
#include <iostream>
using namespace std;
int res;

int main()
{
int n, k = 0;
cin >> n;
while (n--){
int x;
cin >> x;
if (x >= k) res += (x - k) * 6;
else res += (k - x) * 4;
res += 5;
k = x;
}

cout << res;
return 0;
}