PTA甲级——1011

1011 World Cup Betting

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:

1
2
3
4
 W    T    L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1
2
3
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

1
T T W 39.31

思路

​ 大致题意你求最大的赚钱方案和具体赚多少钱,一共三场比赛,每场比赛的投输、赢、平局的赔率都是已知的,然后给你一个公式:(第1场赔率x第2场赔率x第三场赔率65% - 1)x 2 = 赚的钱。

​ 对于赔率是什么不了解,对本道题目其实没有任何影响。

​ 思路:这样思路就不言而喻了的,三场赔率最高分别找出来即可。

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;
int n;
double a[5][5];
char aa[4] = {' ', 'W', 'T', 'L'};
double max(double a, double b) {
return a > b ? a : b;
}

int main()
{
double max1 = 0, max2 = 0, max3 = 0;
int k1 = 0, k2 = 0, k3 = 0;
for (int i = 1; i <= 3;i ++) {
for (int j = 1; j <= 3; j++) {
cin >> a[i][j];
if (i == 1) {
if (a[i][j] > max1) k1 = j;
max1 = max(a[i][j], max1);
}
else if (i == 2) {
if (a[i][j] > max2) k2 = j;
max2 = max(a[i][j], max2);
}
else{
if (a[i][j] > max3) k3 = j;
max3 = max(a[i][j], max3);
}
}
}

printf("%c %c %c %.2lf",aa[k1], aa[k2], aa[k3], (0.65 * max1 * max2 * max3 - 1) * 2.0);
return 0;
}