PTA甲级——1012

1012 The Best Rank

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

1
2
3
4
5
StudentID  C  M  E  A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

1
2
3
4
5
6
7
8
9
10
11
12
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1
2
3
4
5
6
1 C
1 M
1 E
1 A
3 A
N/A

思路

​ 大致意思就是:给你一些人的成绩和id,每份数据有1个id 三个成绩c m e,同时对应有一个平均数a。然后按照a、c、m、e的优先级,输入1个id,然后输出该id其中名次最高的成绩,如果有相同成绩就按照上述的优先级输出成绩名次,观察案例可知之。

代码一(错误???)

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
// 排名并列应该1、1、3、4、5,而不是1、1、2、3、4,否则会有一个测试点不过.这个需要非常注意!!!!!!

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;
typedef pair<string,pair<int,int>> PSI;
const int N = 1e4 + 10;
PSI c[N];
PSI m[N];
PSI e[N];
PSI a[N];

bool cmp1(PSI x,PSI y) {
return x.second.first > y.second.first || (x.second.first == y.second.first && x.first <= y.first);
}

int main()
{
ios::sync_with_stdio(false),cin.tie(0),cout.tie(0);
int n, k;
cin >> n >> k;
for (int i = 1; i <= n; i++) {
string id;
cin >> id >> c[i].second.first >> m[i].second.first >> e[i].second.first;
c[i].first = id;
m[i].first = id;
e[i].first = id;

a[i] = {id, {(c[i].second.first + m[i].second.first + e[i].second.first) / 3,i}};
}

sort(c + 1, c + n + 1, cmp1);
sort(m + 1, m + n + 1, cmp1);
sort(e + 1, e + n + 1, cmp1);
sort(a + 1, a + n + 1, cmp1);

for (int i = 1; i <= n; i++){
if (a[i].second.first != a[i - 1].second.first) a[i].second.second = i;
else a[i].second.second = a[i - 1].second.second;

if (c[i].second.first != c[i - 1].second.first) c[i].second.second = i;
else c[i].second.second = c[i - 1].second.second;

if (m[i].second.first != m[i - 1].second.first) m[i].second.second = i;
else m[i].second.second = m[i - 1].second.second;

if (e[i].second.first != e[i - 1].second.first) e[i].second.second = i;
else e[i].second.second = e[i - 1].second.second;
}

// for (int i = 1; i <= n; i++) cout << e[i].second.second << '\n';
while (k--){
string id;
cin >> id;
for (int i = 1; i <= n; i++) {
if (a[i].first == id) {
cout << a[i].second.second << " A\n";
break;
}
if (c[i].first == id) {
cout << c[i].second.second << " C\n";
break;
}
if (m[i].first == id) {
cout << m[i].second.second << " M\n";
break;
}
if (e[i].first == id) {
cout << e[i].second.second << " E\n";
break;
}
if (i == n) {
cout << "N/A\n";
}
}
}

return 0;
}

代码二

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
#include <cstdio>
#include <algorithm>
using namespace std;
struct node {
int id, best;
int score[4], rank[4];
}stu[2005];
int exist[1000000], flag = -1;
bool cmp1(node a, node b) {return a.score[flag] > b.score[flag];}
int main() {
int n, m, id;
scanf("%d %d", &n, &m);
for(int i = 0; i < n; i++) {
scanf("%d %d %d %d", &stu[i].id, &stu[i].score[1], &stu[i].score[2], &stu[i].score[3]);
stu[i].score[0] = (stu[i].score[1] + stu[i].score[2] + stu[i].score[3]) / 3.0 + 0.5;
}
for(flag = 0; flag <= 3; flag++) {
sort(stu, stu + n, cmp1);
stu[0].rank[flag] = 1;
for(int i = 1; i < n; i++) {
stu[i].rank[flag] = i + 1;
if(stu[i].score[flag] == stu[i-1].score[flag])
stu[i].rank[flag] = stu[i-1].rank[flag];
}
}
for(int i = 0; i < n; i++) {
exist[stu[i].id] = i + 1;
stu[i].best = 0;
int minn = stu[i].rank[0];
for(int j = 1; j <= 3; j++) {
if(stu[i].rank[j] < minn) {
minn = stu[i].rank[j];
stu[i].best = j;
}
}
}
char c[5] = {'A', 'C', 'M', 'E'};
for(int i = 0; i < m; i++) {
scanf("%d", &id);
int temp = exist[id];
if(temp) {
int best = stu[temp-1].best;
printf("%d %c\n", stu[temp-1].rank[best], c[best]);
} else {
printf("N/A\n");
}
}
return 0;
}