PTA甲级——1035

1035 Password

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

1
2
3
4
3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

1
2
3
2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
2
1
team110 abcdefg332

Sample Output 2:

1
There is 1 account and no account is modified

Sample Input 3:

1
2
3
2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

1
There are 2 accounts and no account is modified

思路

大致题意:给出一些人的id和密码,我们需要将成员密码中需要修改的人的id和修改之后的密码输出出来,修改规则为:

  • 1 -> @
  • 0 -> %
  • l -> L,
  • O->o

如果没有需要修改的话就输出**There are N accounts and no account is modified这种语句,但是注意!!!当N=1的时候应该输出为There is 1 account and no account is modified**,一定要注意这里的单复数问题,别问我为什么这样说……….

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
#include <iostream>
#include <algorithm>

using namespace std;
const int N = 1e3 + 10;
int n;
int k;
typedef pair<string, string> PSS;
PSS A[N];

int main() {
int n;
cin >> n;
for (int i = 1; i <= n; i++){
string s1, s2;
cin >> s1 >> s2;
bool flag = false;
for (int i = 0; i < s2.length(); i++) {
if (s2[i] == '1') {
s2[i] = '@';
flag = true;
} else if (s2[i] == '0') {
s2[i] = '%';
flag = true;
} else if (s2[i] == 'l') {
s2[i] = 'L';
flag = true;
} else if (s2[i] == 'O'){
s2[i] = 'o';
flag = true;
}
}
if (flag) {
A[k++] = {s1, s2};
}
}

if (!k){
if (n == 1) cout << "There is " << n << " account and no account is modified";
else cout << "There are " << n << " accounts and no account is modified";
}
else {
cout << k << '\n';
for (int i = 0; i < k; i++) cout << A[i].first << " " << A[i].second << '\n';
}

return 0;
}

// 1 -> @
// 0 -> %
// l -> L,
// O->o