PTA甲级——1041

1041 Be Unique

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

1
7 5 31 5 88 67 88 17

Sample Output 1:

1
31

Sample Input 2:

1
5 888 666 666 888 888

Sample Output 2:

1
None

思路

​ 大致题意:给你一排数,让你找到第一个在这个数列中只出现1次的数,如果不存在这样的数则输出None.

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
#include <iostream>
#include <algorithm>

using namespace std;
const int N = 1e4 + 10, M = 1e5 + 10;
int st[N];
int a[M];

int main()
{
bool flag = false;
int n;
cin >> n;
for (int i = 1; i <= n; i++) {
int x;
cin >> x;
a[i] = x;
st[x]++;
}

for (int i = 1; i <= n;i++){
if (st[a[i]] == 1) {
cout << a[i];
return 0;
}
}

cout << "None";
return 0;
}