PTA甲级——1065

1065 A+B and C (64bit)

Given three integers A, B and C in (−263,263), you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1). Each line should ends with '\n'.

Sample Input:

1
2
3
4
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

1
2
3
Case #1: false
Case #2: true
Case #3: false

Thanks to Jiwen Lin for amending the test data.

思路

​ 略了

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
#include <iostream>
using namespace std;
typedef long long LL;

int main(){
int n;
cin >> n;
for (int i = 1; i <= n; i++) {
LL a, b, c;
cin >> a >> b >> c;
LL sum = a + b;

if(a > 0 && b > 0 && sum < 0) {
printf("Case #%d: true\n", i);
} else if(a < 0 && b < 0 && sum >= 0){
printf("Case #%d: false\n", i);
} else if(sum > c) {
printf("Case #%d: true\n", i);
} else {
printf("Case #%d: false\n", i);
}
}
return 0;
}